WinUAE 0816 R 4         WinUAE 0817 R 3         zurück Amiga         zurück zur Hauptseite

Ultimate Amiga Emulator

Amiga4ever WinUAE 0.8.8 Release 8

Amiga4ever von Cloanto läuft bei mir jetzt auf einen PC Celeron 600 - 128 MB RAM. Vorhanden sind 2 Festplatten 10 GB und 13 GB. Nun möchte ich über meine bisherigen Erfahrungen berichten.

Von der CloantoCD liess sich AmigaOS 3.1 einfach installieren. Nur bei den Versionen OS 3.5 und OS 3.9 gibt es Probleme bei dem Installieren von den CD's. Diese Versionen habe ich per NullModemKabel vom Amiga auf den PC Übertragen. Ich meine für AOS 3.9 braucht man mindestens 128 MB Ram, sonst hat das keinen Sinn.

Für das übertragen per NullModemKabel ist das Programm AmigaExplorer auf der CD. Zu Beachten ist das beide Rechner die gleiche Baud-Rate und die gleiche Portnummer haben. Z.b. beide 57600 baud und Unit 1 (Amiga) Com 1 (PC). Nun hatte ich WinUAE zuerst über das Betriebssystem Windows ME laufen. ME bedeutet wohl tatsächlich more errors, denn es lies sich keine DFÜ-Verbindung herstellen. Aber durch nachfragen in den NewsGroups und Mailinglisten habe ich erfahren, dass es mit Win98 auch möglich ist, mit der AmigaEmulation ins Netz zu kommen.

Ab Version WinUAE 0817 R 3 geht es auch mit WinME.

Nun wollte ich WinME erst mal behalten und zusätzlich Win98 installieren. Dafür gibt es Tools sog. BootManager, aber nachdem ich mir die Dinger bzw. die ReadMeTexte genauer angesehen habe, wollte ich mir so was nicht installieren. Und nachdem ich mein BIOS auf dem PC genau studiert hatte, sah ich eine Möglichkeit beide Systeme zu benutzen. Man kann in meinem BIOS einstellen, von wo aus gebootet werden soll.

Als erstes baute ich meine erste Platte aus(WinME) bzw. entfernte ich das DatenKabel und konnte nun auf die andere Platte Win98 aufspielen. Die erste Platte dann wieder angeschlossen und jetzt kann ich über BIOS einstellen, ob ME oder 98 gebootet wird. HDD0 oder HDD1.

Es gibt nun ein PC-Seitig ein BootMenu, wo man die gewünschten Einstellungen für die AmigaEmulation treffen kann. Ich benutze WinUAE mit AOS 3.9 KickRom 3.1. Mit Fellow kann man auch ältere AmigaVersionen emulieren. Das ist mit den enthaltenen KickRom's 1.0, 1.1, 1.2, 1.3, 2.0, 2.04, 2.1 und 3.0 möglich.

CloantoMenu

Die Bsd-Socket-Library lasse ich emulieren, das bedeutet, das ich mit dem PC online gehe und dann mit AmigaProgrammen darauf zugreife. Also mit YAM, AWebII und MicroDot2. Also brauche ich kein Miami oder Genesis.

WinUAE-Menu

WinUAE-Menu1

Nun einige Programme, die ich mehr oder weniger getestet habe.
Alle Programme sind natürlich registriert.

Text-Programme

Diesen Text schreibe ich mit GoldED 4 Pro und bis auf die Tastaturkürzel, die ich noch nicht alle umsetzen kann, läuft es gut. Da greife ich eben über Menu auf alle Befehle. FinalWriter und Wordworth habe ich nur kurz angetestet. Da kann ich noch nix genaues schreiben. Der Organizer läuft auch.

Grafik

Von Haus aus ist PPaint mit auf Amiga4ever-CD und da gibt es keine Probleme. Arteffect funktioniert auch gut und schneller als auf meinen A-1200. PicManager klappt nach ersten Versuchen.

DFÜ - InterNET

Hier waren die ersten Probleme zu lösen. Wie schon geschrieben, muss man die BSD-socket-library emulieren und das geht nicht über WinME, sondern nur über Win98. Ob Win95 klappt, probiere ich nicht. :) Nach meinen Erfahrungen ist es gut, wenn man YAM so startet, als ob man Online ist. Dann sucht das Programm die BSD-socket-Library - sie ist noch nicht vorhanden und der Rechner zeigt dann die Win98 Seite mit der DFÜ-Verbindung. Dort auf Verbindung herstellen und wenn die Verbindung steht, kommt wieder die Amiga Workbench mit YAM und YAM beginnt zu arbeiten. Um die DFÜ-Verbindung wieder zu trennen kommt man mit ALT und TAB auf den WindowsDesktop und wieder zurück zum Amiga.

AWebII, die Version von der OS3.9-CD funktioniert auch gut, eben bis auf das, was nur Winzigweich kann. :)) Die meisten Probleme bekam ich mit MicroDot2. Das Programm wollte nicht starten. Nicht mit meinen Amiga-Kopien. Neuinstalliert mal ja mal nein. :(( Da weiß ich nicht, warum das so ist. :(( Aber eine Möglichkeit habe ich natürlich gefunden. :) Wenn ich das Programm ohne Verzeichnis nach WBStartup verlege, dann geht es! Also MicroDot, Data, MicroDot.prefs, Icons und CM (ContaktManager) ins Verzeichnis WBStartup. So geht es und nach meinen Erfahrungen, nur so! Wenn es beendet ist, lässt sich MD auch nicht mit Doppelklick in der WBStartup starten. ;(( Also benutze ich es über die WBStartup.

WinUAE-Menu2

Spiele

Das Spiel BackGammon spielt meine Frau gerne. Es funktioniert auch teilweise, nur sollte man darauf achten, das in den Prefs Kein Ton eingeschaltet ist. Sonst kann man es nicht normal beenden und dann hilft nur ALT und F4. Die Spielfunktion verdoppeln klappt leider nicht, aber meine Frau benutzt sie auch nicht und ist so zufrieden.

Mein LieblingsTetris 2000AD funktioniert auch. Es wird mit JoyStick gespielt. Keine besonderen Vorkommnisse, das heißt, vielleicht sollte ich es auf einen anderen Screen spielen. Momentan habe ich uaegfx 800 x 600.

HBMonopoly klappt auch, bis auf die Tastaturkürzel. Es geht aber.

Bei meinem BowlingSpiel KingPin habe ich noch Probleme. Die Demo läuft, aber meine Vollversion hat sich noch nicht dazu bewegenlassen. Und nun habe ich für » KingPin « auch eine Lösung gefunden. Und zwar muss ich bei der Konfiguration bei Display die Einstellung Full Screen deaktivieren. Dann klappt es mit Bowling.

Bislang habe ich die WinUAE-Version benutzt, die auf der CD war, aber es gibt auch schon wieder neuere Versionen, die ich noch testen muss.

WinUAE 0816 Release 4

Eine neue Version ist 0816 Release 4. Und die emuliert eine 68040-CPU. Also - learning by doing. Auf meiner Platte habe ich mir eine neues Verzeichnis eingerichtet, wo die neueste Version drin ist. Ausserdem das neueste AmigaOS, also AOS3.9 mit BoingBag1 , das entspricht dann Workbench Version 45.2.

WinUAE-Menu3

Als Bildschirm benutze ich für meine Versuche UAEgfx 800x600 8-bit 60 Hz. Als ChipSatz kann man zwischen OCS, ECS und AGA wählen. Zuerst nehme ich OCS. Um diese Workbench zu booten, brauche ich ca. 40 sec, die Zeit könnte man verkürzen, indem man auf das Hintergrundbild und das laden von Programmen verzichtet. Mit ECS sind es ca. 30 sec und mit AGA ca. 35 sec. Die neueste WinUAE-Version 0816 R 4 ist wieder für mich gebrauchsfähig. Bei anderen Versionen zb. 0816 R 1 lief die Uhr bei mir zu schnell und auch das eintippen von Befehlen in die Shell funktionierte nicht, da es nicht möglich war, einzelne Buchstaben zu tippen und immer gleich per Tastendruck mehrere gleiche kamen. Jetzt benutze ich ich die 68040-CPU - 8 MB ChipRam - 64 MB ZorroIII-FastRam.

WinUAE-Menu4

Für mich ist es jetzt eine wahre Freude mit Multiview Bilder zu laden, das geht jetzt ruckzuck, so schnell kann das mein echter Amiga 1200 030/40 mit Multiview nicht. Da war früher immer lange warten angesagt.

WinUAE-Menu5

Da ich eine Picasso 96 Grafikkarte emuliere nehme ich als ChipSatz ECS. Laut Dokumentation soll die emulierte BSD-socket-library noch nicht richtig funktionieren und ich teste erst mal mit YAM, ob und welche Fehler es gibt. Und da kann ich bislang keine Fehler feststellen.

Aufgefallen ist mir, dass die neue Version von WinUAE bei meinem SKAT-Spiel die Karten nicht richtig mischen kann und ich immer wieder das gleiche Blatt bekomme. Gut, auf das Spiel kann ich verzichten, der Gegner ist sowieso noch nicht so ausgereift und spielt IMHO manchmal ziemlich schlecht.
Nun nehme ich für Spiele andere Einstellungen und damit geht es dann gut.

Bisher hatte ich meine Festplatten bei den WinUAE-Einstellungen als Ordner WinHD_x deklariert. Und genauso habe ich es auch mit den CD-ROM-Laufwerken gemacht. WinCD_x. Darauf hätte ich verzichten können. Workbench und Arbeit sind die einzigen zwei Verzeichnisse, die ich angeben muss. Und mit einem Häkchen 'PC-Laufwerke mit anzeigen' sehe ich alle Laufwerke.

WinUAE-Menu6

Das hat den Nachteil, das die PC-Laufwerke mit Namen angezeigt werden und ich auf den PC auch System und Work habe. Der übersicht halber nenne ich meine Verzeichnisse auf den Amiga dann Workbench und Arbeit.

Mein MicroDot läßt sich nun auch wieder ohne Tricks starten, also denke ich mal, das ich nun einen gut funktionierenden Amiga auf meiner PC-Plattform habe.

Sonntag, der 12. August 2001... Aus irgendeinen Grund wollte mein PC nicht mehr mit meinem EmuAmiga WinUAE 016R4 zusammenarbeiten. Grosses Problem und ich hab lange rumprobiert, den Fehler zu finden. Plötzlich ist es so, das sich die PC-Laufwerke nicht mehr anzeigen lassen und bei gesetzten Häkchen startet der Amiga nicht mehr.

Upps... Fehler gefunden. Hatte im Gerätemanager Disketten-LW-Controller deaktiviert und darum ging es nicht. Wieder aktiviert - alles wieder Okay. Kleiner Klick - Große Wirkung ;((

Andere WinUAE-Versionen wurden erkannt. ;(

Hier nun meine Configuration, die ich mit AmigaOS 3.9 benutze:


config_description=ROM 3.1, 68040, TCP/IP, 80 MB, sound, TEST
config_info=Konfig mit allen Optionen
Avoid_cmov=True
win32.file_path=none
win32.rom_path=../shared/rom/
win32.floppy_path=../shared/adf/
win32.hardfile_path=../shared/hdf/
win32.middle_mouse=false
win32.logfile=false
win32.sound_style=waveout_looping
win32.sound_tweak=4
win32.map_drives=true
win32.serial_port=none
win32.parallel_port=Canon Bubble-Jet BJC-240
win32.iconified_nospeed=false
win32.iconified_nosound=false
win32.ctrl_f11_is_quit=false
win32.midiout_device=-1
win32.midiin_device=-1
win32.directx6=true
use_gui=false
use_debugger=false
kickstart_rom_file=..\shared\rom\kick310.rom
kickstart_key_file=rom.key
kickshifter=true
enforcer=false
pci_devices=
floppy0=
floppy1=
floppy2=
floppy3=
nr_floppies=4
parallel_on_demand=false
serial_on_demand=false
sound_output=exactv sound_channels=mono
sound_bits=16
sound_min_buff=1500
sound_max_buff=1500
sound_frequency=44100
sound_interpol=none
sound_pri_time=0
sound_pri_cutoff=0
comp_trustbyte=indirect
comp_trustword=indirect
comp_trustlong=indirect
comp_trustnaddr=indirect
comp_nf=true
comp_constjump=true
comp_flushmode=hard
compforcesettings=true
compfpu=true
comp_midopt=false
comp_lowopt=false
avoid_dga=false
avoid_vid=false
cachesize=8192
joyport0=mouse
joyport1=jbd2
bsdsocket_emu=true
gfx_chipset=aga
gfx_framerate=1
gfx_width=720
gfx_height=576
gfx_lores=false
gfx_linemode=double
gfx_correct_aspect=true
gfx_fullscreen_amiga=true
gfx_fullscreen_picasso=true
gfx_center_horizontal=smart
gfx_center_vertical=smart
gfx_colour_mode=16bit
gfx_32bit_blits=false
gfx_immediate_blits=false
gfx_ntsc=false
show_leds=true
fastmem_size=8
a3000mem_size=0
z3mem_size=64
bogomem_size=0
gfxcard_size=8
chipmem_size=16
cpu_speed=max
cpu_type=68040
cpu_compatible=false
autoconfig=true
accuracy=2
log_illegal_mem=false
kbd_lang=us
filesystem=rw,WorkBench:C:\AmigaOS39\shared\dir\WorkBench
filesystem=rw,Arbeit:C:\AmigaOS39\shared\dir\Arbeit


und für Spiele benutze ich:


config_description=ROM 3.1, 68020, TCP/IP, 80 MB, sound, no GUI
config_info=
sound_channels=stereo
sound_channels=stereo
sound_channels=stereo
sound_channels=stereo
sound_channels=stereo
sound_channels=mono
gfx_32bit_blits=false
sound_channels=mono
enforcer=false
win32.directx6=true
gfx_test_speed=no
gfxlib_replacement=no
sound_channels=0
win32.file_path=none
sound_channels=mono
sound_channels=stereo
sound_channels=stereo
sound_channels=stereo
sound_channels=stereo
sound_channels=stereo
win32.rom_path=../shared/rom/
win32.floppy_path=../shared/adf/
win32.hardfile_path=../shared/hdf/
win32.middle_mouse=false
win32.logfile=false
win32.sound_style=waveout_looping
win32.sound_tweak=0
win32.map_drives=true
win32.serial_port=none
win32.parallel_port=Canon Bubble-Jet BJC-240
win32.iconified_nospeed=false
win32.iconified_nosound=false
win32.ctrl_f11_is_quit=false
win32.midiout_device=-1
win32.midiin_device=-1
use_gui=false
use_debugger=false
kickstart_rom_file=..\shared\rom\kick310.rom
kickstart_key_file=rom.key
kickshifter=false
pci_devices=
floppy0=
floppy1=
floppy2=
floppy3=
nr_floppies=4
parallel_on_demand=false
serial_on_demand=false
sound_output=normal
sound_channels=stereo
sound_bits=8
sound_min_buff=1500
sound_max_buff=1500
sound_frequency=22050
sound_interpol=none
sound_pri_time=0
sound_pri_cutoff=0
comp_trustbyte=indirect
comp_trustword=indirect
comp_trustlong=indirect
comp_trustnaddr=indirect
comp_nf=true
comp_constjump=true
comp_flushmode=soft
compforcesettings=true
compfpu=true
comp_midopt=false
comp_lowopt=false
avoid_dga=false
avoid_vid=false
cachesize=0
joyport0=mouse
joyport1=joy0
bsdsocket_emu=false
gfx_framerate=1
gfx_width=800
gfx_height=600
gfx_lores=false
gfx_linemode=double
gfx_correct_aspect=false
gfx_fullscreen_amiga=false
gfx_fullscreen_picasso=true
gfx_center_horizontal=none
gfx_center_vertical=none
gfx_colour_mode=8bit
gfx_immediate_blits=false
gfx_ntsc=false
show_leds=false
chipset=aga
collision_level=sprites
fastmem_size=8
a3000mem_size=0
z3mem_size=64
bogomem_size=0
gfxcard_size=2
chipmem_size=4
finegrain_cpu_speed=max
cpu_type=68020/68881
cpu_compatible=false
autoconfig=true
accuracy=2
log_illegal_mem=false
kbd_lang=us
filesystem=rw,WorkBench:C:\AmigaOS39\shared\dir\WorkBench
filesystem=rw,Arbeit:C:\AmigaOS39\shared\dir\Arbeit


So klappt es mit Bowling, Skat und anderen Spielen...

WinUAE 0817 Release 3

Mit der Version 0.8.17 R 3 wird die Bsd-socket-library auch mit WinME emuliert.

WinUAE

Das habe ich erstmal mit AmigaOS 3.1 ausprobiert und es hat angenehm schnell funktioniert.


Die neueste WinUAE-Version ist jetzt schon 0.8.21 R 2 vom 08.03.2002 und man bekommt sie z.b. unter

www.winuae.de oder www.winuae.net

und von dort aus gibt es interessante Links zum Thema.

Hier noch meine aktuelle Konfiguration zu 0.8.17 R 3:


config_description=ROM 3.1, 68040, TCP/IP, 80 MB, sound
config_info=
win32.rom_path=../shared/rom/
win32.floppy_path=../shared/adf/
win32.hardfile_path=../shared/hdf/
win32.middle_mouse=false
win32.logfile=false
win32.sound_style=waveout_looping
win32.sound_tweak=0
win32.sound_sync=1
win32.sound_speed_tweak=0
win32.sound_lag=15
win32.map_drives=true
win32.serial_port=none
win32.parallel_port=none
win32.iconified_nospeed=false
win32.iconified_nosound=false
win32.ctrl_f11_is_quit=false
win32.midiout_device=-1
win32.midiin_device=-1
win32.no_overlay=false
use_gui=false
use_debugger=false
kickstart_rom_file=C:\..\shared\rom\kick310.rom
kickstart_key_file=C:\..\shared\rom\rom.key
kickshifter=false
pci_devices=
floppy0=
floppy1=df1.adf
floppy2=df2.adf
floppy3=df3.adf
nr_floppies=1
parallel_on_demand=false
serial_on_demand=false
sound_output=exact
sound_channels=stereo
sound_bits=16
sound_min_buff=1500
sound_max_buff=1500
sound_frequency=22050
sound_interpol=none
sound_pri_time=0
sound_pri_cutoff=0
comp_trustbyte=direct
comp_trustword=direct
comp_trustlong=direct
comp_trustnaddr=direct
comp_nf=true
comp_constjump=true
comp_flushmode=soft
compforcesettings=false
compfpu=true
comp_midopt=false
comp_lowopt=false
avoid_dga=false
avoid_vid=false
cachesize=4096
joyport0=mouse
joyport1=joy0
bsdsocket_emu=true
gfx_framerate=1
gfx_width=800
gfx_height=600
gfx_lores=false
gfx_linemode=double
gfx_correct_aspect=false
gfx_fullscreen_amiga=true
gfx_fullscreen_picasso=true
gfx_center_horizontal=none
gfx_center_vertical=none
gfx_colour_mode=16bit
gfx_immediate_blits=false
gfx_ntsc=false
show_leds=false
chipset=ocs
collision_level=sprites
fastmem_size=0
a3000mem_size=0
z3mem_size=64
bogomem_size=0
gfxcard_size=8
chipmem_size=16
finegrain_cpu_speed=max
cpu_type=68040
cpu_compatible=false
accuracy=2
log_illegal_mem=false
kbd_lang=us
filesystem=rw,Workbench:..shared\dir\Workbench
filesystem=rw,Arbeit:..\shared\dir\Arbeit

So klappt es wunderbar.

zum Anfang
zurück zur Hauptseite

Autor:   Karl-Heinz Bader    E-Mail:   charly-ham@t-online.de